view debian/rules @ 14:6273a788c4fd

removed bashism
author meillo@marmaro.de
date Sat, 19 Apr 2008 11:38:29 +0200
parents 27f96c3b8224
children 3ce5429cd219
line wrap: on
line source

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1


build:

clean:
	dh_testdir
	dh_testroot
	dh_clean 

install:
	dh_testdir
	dh_testroot
	dh_clean -k 
	dh_installdirs

	# Add here commands to install the package into debian/genwebgallery.
	$(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install


# Build architecture-independent files here.
binary-indep: install
	dh_testdir
	dh_testroot
	dh_installchangelogs ChangeLog
	dh_installdocs
# dh_installexamples
#	dh_install
#	dh_installmenu
#	dh_installdebconf	
#	dh_installmime
#	dh_installinit
	dh_installman
# dh_link
# dh_strip
	dh_compress
	dh_fixperms
#	dh_perl
#	dh_makeshlibs
	dh_installdeb
# dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

# Build architecture-dependent files here.
binary-arch:

binary: binary-indep

.PHONY: build clean binary-indep binary-arch binary install configure