genwebgallery

view debian/rules @ 12:27f96c3b8224

fixed hyphen-minus-conflict in man page; refactored debian/rules (removed a lot)
author meillo@marmaro.de
date Sat, 24 Nov 2007 23:29:16 +0100
parents 626dacb5193e
children 3ce5429cd219
line source
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 build:
15 clean:
16 dh_testdir
17 dh_testroot
18 dh_clean
20 install:
21 dh_testdir
22 dh_testroot
23 dh_clean -k
24 dh_installdirs
26 # Add here commands to install the package into debian/genwebgallery.
27 $(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install
30 # Build architecture-independent files here.
31 binary-indep: install
32 dh_testdir
33 dh_testroot
34 dh_installchangelogs ChangeLog
35 dh_installdocs
36 # dh_installexamples
37 # dh_install
38 # dh_installmenu
39 # dh_installdebconf
40 # dh_installmime
41 # dh_installinit
42 dh_installman
43 # dh_link
44 # dh_strip
45 dh_compress
46 dh_fixperms
47 # dh_perl
48 # dh_makeshlibs
49 dh_installdeb
50 # dh_shlibdeps
51 dh_gencontrol
52 dh_md5sums
53 dh_builddeb
55 # Build architecture-dependent files here.
56 binary-arch:
58 binary: binary-indep
60 .PHONY: build clean binary-indep binary-arch binary install configure