diff debian/rules @ 12:27f96c3b8224 deb_0.4-2

fixed hyphen-minus-conflict in man page; refactored debian/rules (removed a lot)
author meillo@marmaro.de
date Sat, 24 Nov 2007 23:29:16 +0100
parents 626dacb5193e
children 3ce5429cd219
line wrap: on
line diff
--- a/debian/rules	Fri Nov 23 23:04:36 2007 +0100
+++ b/debian/rules	Sat Nov 24 23:29:16 2007 +0100
@@ -10,46 +10,14 @@
 #export DH_VERBOSE=1
 
 
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-	CFLAGS += -O0
-else
-	CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-	dh_testdir
-	# Add here commands to configure the package.
-
-	touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-	dh_testdir
-
-	# Add here commands to compile the package.
-	$(MAKE)
-	#docbook-to-man debian/genwebgallery.sgml > genwebgallery.1
-
-	touch $@
+build:
 
 clean:
 	dh_testdir
 	dh_testroot
-	rm -f build-stamp configure-stamp
-
-	# Add here commands to clean up after the build process.
-	-$(MAKE) clean
-
 	dh_clean 
 
-install: build
+install:
 	dh_testdir
 	dh_testroot
 	dh_clean -k 
@@ -60,39 +28,33 @@
 
 
 # Build architecture-independent files here.
-binary-indep: build install
+binary-indep: install
 	dh_testdir
 	dh_testroot
 	dh_installchangelogs ChangeLog
 	dh_installdocs
-	dh_installexamples
+# dh_installexamples
 #	dh_install
 #	dh_installmenu
 #	dh_installdebconf	
-#	dh_installlogrotate
-#	dh_installemacsen
-#	dh_installpam
 #	dh_installmime
-#	dh_python
 #	dh_installinit
-#	dh_installcron
-#	dh_installinfo
 	dh_installman
-	dh_link
-	dh_strip
+# dh_link
+# dh_strip
 	dh_compress
 	dh_fixperms
 #	dh_perl
 #	dh_makeshlibs
 	dh_installdeb
-	dh_shlibdeps
+# dh_shlibdeps
 	dh_gencontrol
 	dh_md5sums
 	dh_builddeb
 
 # Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
+binary-arch:
 
-binary: binary-indep binary-arch
+binary: binary-indep
+
 .PHONY: build clean binary-indep binary-arch binary install configure