comparison debian/rules @ 12:27f96c3b8224 deb_0.4-2

fixed hyphen-minus-conflict in man page; refactored debian/rules (removed a lot)
author meillo@marmaro.de
date Sat, 24 Nov 2007 23:29:16 +0100
parents 626dacb5193e
children 3ce5429cd219
comparison
equal deleted inserted replaced
11:83e01434937f 12:27f96c3b8224
8 8
9 # Uncomment this to turn on verbose mode. 9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1 10 #export DH_VERBOSE=1
11 11
12 12
13 13 build:
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27
28 touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE)
38 #docbook-to-man debian/genwebgallery.sgml > genwebgallery.1
39
40 touch $@
41 14
42 clean: 15 clean:
43 dh_testdir 16 dh_testdir
44 dh_testroot 17 dh_testroot
45 rm -f build-stamp configure-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) clean
49
50 dh_clean 18 dh_clean
51 19
52 install: build 20 install:
53 dh_testdir 21 dh_testdir
54 dh_testroot 22 dh_testroot
55 dh_clean -k 23 dh_clean -k
56 dh_installdirs 24 dh_installdirs
57 25
58 # Add here commands to install the package into debian/genwebgallery. 26 # Add here commands to install the package into debian/genwebgallery.
59 $(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install 27 $(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install
60 28
61 29
62 # Build architecture-independent files here. 30 # Build architecture-independent files here.
63 binary-indep: build install 31 binary-indep: install
64 dh_testdir 32 dh_testdir
65 dh_testroot 33 dh_testroot
66 dh_installchangelogs ChangeLog 34 dh_installchangelogs ChangeLog
67 dh_installdocs 35 dh_installdocs
68 dh_installexamples 36 # dh_installexamples
69 # dh_install 37 # dh_install
70 # dh_installmenu 38 # dh_installmenu
71 # dh_installdebconf 39 # dh_installdebconf
72 # dh_installlogrotate
73 # dh_installemacsen
74 # dh_installpam
75 # dh_installmime 40 # dh_installmime
76 # dh_python
77 # dh_installinit 41 # dh_installinit
78 # dh_installcron
79 # dh_installinfo
80 dh_installman 42 dh_installman
81 dh_link 43 # dh_link
82 dh_strip 44 # dh_strip
83 dh_compress 45 dh_compress
84 dh_fixperms 46 dh_fixperms
85 # dh_perl 47 # dh_perl
86 # dh_makeshlibs 48 # dh_makeshlibs
87 dh_installdeb 49 dh_installdeb
88 dh_shlibdeps 50 # dh_shlibdeps
89 dh_gencontrol 51 dh_gencontrol
90 dh_md5sums 52 dh_md5sums
91 dh_builddeb 53 dh_builddeb
92 54
93 # Build architecture-dependent files here. 55 # Build architecture-dependent files here.
94 binary-arch: build install 56 binary-arch:
95 # We have nothing to do by default.
96 57
97 binary: binary-indep binary-arch 58 binary: binary-indep
59
98 .PHONY: build clean binary-indep binary-arch binary install configure 60 .PHONY: build clean binary-indep binary-arch binary install configure