2011-07-14 |
markus schnalke |
Removed unused second arg of msg_spool_read()
|
2011-07-14 |
markus schnalke |
Argument of read_queue() was unused, thus removed
|
2011-07-14 |
markus schnalke |
Minor refactoring
|
2011-07-14 |
markus schnalke |
Minor clarifications in man pages (do_queue)
|
2011-09-03 |
markus schnalke |
added local_rcpts() and remote_rcpts() for later use
|
2011-09-03 |
markus schnalke |
improved comments and debug messages
|
2011-09-03 |
markus schnalke |
refactoring: ``insourced'' create_msg_out_list()
|
2011-08-31 |
markus schnalke |
bumped version number
|
2011-08-31 |
markus schnalke |
Added tag 0.3.3 for changeset 60bb2dbe2866
|
2011-08-31 |
markus schnalke |
In the tests: replaced logname(1) with $LOGNAME
0.3.3
|
2011-08-31 |
markus schnalke |
removed -dev postfix on version number
|
2011-08-31 |
markus schnalke |
updated ChangeLog and NEWS
|
2011-08-29 |
markus schnalke |
Minor fixes in man pages, reported by lintian(1)
|
2011-08-27 |
markus schnalke |
updated ChangeLog and NEWS
|
2011-08-27 |
markus schnalke |
updated dates and version
|
2011-08-27 |
markus schnalke |
little typing error
|
2011-08-27 |
markus schnalke |
Added debug level 9 for msgs to stderr during reading config
|
2011-08-27 |
markus schnalke |
refactoring, partly also related to set_euidgid()
|
2011-08-27 |
markus schnalke |
Security fix! Correct handling of seteuid() return value
|
2011-07-13 |
markus schnalke |
Fixed local-part only address patterns in route conditions
|
2011-07-13 |
markus schnalke |
Switched back from 127.0.0.1 to localhost
|
2011-06-03 |
meillo |
Bumped version number
|
2011-06-03 |
meillo |
Added tag 0.3.2 for changeset 45a64a875162
|
2011-06-03 |
meillo |
Updated version
0.3.2
|
2011-06-03 |
meillo |
Updated version and date
|
2011-06-03 |
meillo |
Updated ChangeLog and NEWS
|
2011-06-03 |
meillo |
Fixed an important bug with folded headers!
|
2011-06-03 |
meillo |
hinted that the debug output of folded headers prints only the
|
2011-04-28 |
meillo |
refactoring
|
2011-04-28 |
meillo |
cosmetic changes
|
2011-04-28 |
meillo |
refactoring in the small
|
2011-04-28 |
meillo |
connect_error_fail affects pipe commands too
|
2011-04-28 |
meillo |
reworked allowed and denied addrs for routes
|
2011-04-25 |
meillo |
heavy restructuring of masqmail.route(5) (sections)
|
2011-04-25 |
meillo |
added comments
|
2011-04-25 |
meillo |
small wording change
|
2011-04-25 |
meillo |
trival wording change
|
2011-04-24 |
meillo |
null-terminated the decoded base64 strings
|
2011-04-24 |
meillo |
removed protocol option from route config
|
2011-04-24 |
meillo |
reworked online_detect to the simpler online_query
|
2011-04-24 |
meillo |
bug fix: off-by-one in pipe aliases
|
2011-04-24 |
meillo |
added alias examples to man page
|
2011-04-24 |
meillo |
bug fix: inverted condition
|
2011-04-24 |
meillo |
clarified local_addresses in man page
|
2011-04-24 |
meillo |
refactored complex conditions
|
2010-12-09 |
markus schnalke |
manual formating of Received: hdrs; changed hdr for local receival
|
2010-12-09 |
markus schnalke |
replaced header_fold() with a better implementation
|
2010-12-09 |
markus schnalke |
improved unused function header_fold()
|
2010-12-09 |
markus schnalke |
refactoring
|
2010-12-09 |
markus schnalke |
free memory in spool read for continuation header lines
|
2010-12-09 |
markus schnalke |
fixed compile error; removed PROT_BSMTP; made protocol names ucase
|
2010-12-09 |
markus schnalke |
refactoring
|
2010-12-09 |
markus schnalke |
added a description of how I create a masqmail release
|
2010-12-09 |
markus schnalke |
ran aclocal and autoconf
|
2010-12-09 |
markus schnalke |
updated devel/list-versions to detect version number suffixes
|
2010-12-09 |
markus schnalke |
bumped version number
|
2010-12-08 |
markus schnalke |
Added tag 0.3.1 for changeset 5a93bdc261ba
|
2010-12-08 |
markus schnalke |
No, we don't have that many bugs any more, I believe. ;-)
0.3.1
|
2010-12-08 |
markus schnalke |
updated ChangeLog, NEWS and date/version in the man pages
|
2010-12-08 |
markus schnalke |
mark -qo (without argument) obsolete
|
2010-12-08 |
markus schnalke |
reformating of code
|
2010-12-07 |
markus schnalke |
FIXME comment: where to log while reading the config file?
|
2010-12-07 |
markus schnalke |
updated ChangeLog and NEWS
|
2010-12-07 |
markus schnalke |
further, minor, improvements to man/masqmail.8
|
2010-12-07 |
markus schnalke |
Heavily reworked man/masqmail.8
|
2010-12-07 |
markus schnalke |
recognize the program name `newaliases' too
|
2010-12-07 |
markus schnalke |
improved man/masqmail.8 heavily
|
2010-12-07 |
markus schnalke |
-q and -qo are non-exclusive
|
2010-12-07 |
markus schnalke |
modes are now enforced exclusive
|
2010-12-06 |
markus schnalke |
heavy refactoring of deliver.c
|
2010-12-06 |
markus schnalke |
moved some code around
|
2010-12-06 |
markus schnalke |
added -bm for mode accept (the other MTAs have it too)
|
2010-12-06 |
markus schnalke |
minor refactorings and cleanups
|
2010-12-04 |
markus schnalke |
for -t cmdline args are now added to the rcpt list instead of substracted
|
2010-12-03 |
markus schnalke |
removed comment, see previous commit
|
2010-12-03 |
markus schnalke |
fixed `To: alice, bob' with -t
|
2010-12-03 |
markus schnalke |
parse.c: comments, better debugging, tiny refactoring
|
2010-12-03 |
markus schnalke |
refactoring in the small
|
2010-12-03 |
markus schnalke |
heavy refactoring in the small of parse.c
|
2010-12-03 |
markus schnalke |
refactoring in the small
|
2010-12-03 |
markus schnalke |
comment: problems with `To: alice, bob' and -t
|
2010-12-03 |
markus schnalke |
removed ACC_DEL_RCPTS because it's always used with ACC_RCPT_FROM_HEAD
|
2010-12-03 |
markus schnalke |
comments (should we really exit failure in this case?)
|
2010-12-03 |
markus schnalke |
refactored mode_accept()
|
2010-12-03 |
markus schnalke |
removed obsolete commented code
|
2010-12-03 |
markus schnalke |
comments and a small refactoring
|
2010-12-02 |
markus schnalke |
removed now obsolete exit_code
|
2010-12-02 |
markus schnalke |
s/EXIT_SUCCESS/0/ && s/EXIT_FAILURE/1/
|
2010-12-02 |
markus schnalke |
fixed previous commit and excluded mode_version() from main()
|
2010-12-02 |
markus schnalke |
substituted get_progname() with a call to strrchr()
|
2010-12-02 |
markus schnalke |
made default mode sensible
|
2010-12-01 |
markus schnalke |
fixed -oem by removing it ;-)
|
2010-12-01 |
markus schnalke |
fixed -oi to really be the same as -i
|
2010-11-04 |
markus schnalke |
updated ChangeLog
|
2010-11-04 |
markus schnalke |
removed a magic number from time_interval()
|
2010-11-04 |
markus schnalke |
removed the obsolete pos argument from time_interval()
|
2010-11-04 |
markus schnalke |
updated ChangeLog and NEWS
|
2010-11-04 |
markus schnalke |
improved man/masqmail.8 in various ways but mostly for -oem
|
2010-11-04 |
markus schnalke |
moved run_queue to a new function
|
2010-11-04 |
markus schnalke |
moved the queue manipulation code to an new function
|
2010-11-04 |
markus schnalke |
refactored the cmdline argument processing
|
2010-11-01 |
markus schnalke |
refactored processing of -oXXX options
|
2010-11-01 |
markus schnalke |
ignoring -m switch now
|
2010-10-28 |
markus schnalke |
SMTP client: tries EHLO now always first
|
2010-10-27 |
markus schnalke |
removed ADDR_FLAG_NOEXPAND as it is not needed anymore
|
2010-10-25 |
markus schnalke |
renamed `alias_local_cmp' to `localpartcmp'
|
2010-10-25 |
markus schnalke |
renamed `alias_local_caseless' to `caseless_matching'
|
2010-10-25 |
markus schnalke |
made addr_isequal() and addr_isequal_parent() more flexible
|
2010-10-25 |
markus schnalke |
added myself to the copyright notice of route.c
|
2010-10-25 |
markus schnalke |
removed duplicated function prototypes
|
2010-10-25 |
markus schnalke |
refactored alias.c heavily
|
2010-10-25 |
markus schnalke |
minor improvements in wordings
|
2010-10-22 |
markus schnalke |
refactoring: new function split_rcpts() replaces two others
|
2010-10-22 |
markus schnalke |
debug msgs: improved the display of function return values
|
2010-10-22 |
markus schnalke |
removed additional new lines at the end of debug messages
|
2010-10-22 |
markus schnalke |
renamed the default route for the local net
|
2010-10-21 |
markus schnalke |
improved comments slightly
|
2010-07-26 |
meillo |
next version will be 0.3.1
|
2010-07-26 |
meillo |
Added tag 0.3.0 for changeset 4f999b3ee49d
|
2010-07-23 |
meillo |
updated ChangeLog and NEWS
0.3.0
|