2011-04-25 |
meillo |
small wording change
|
2011-04-25 |
meillo |
trival wording change
|
2011-04-24 |
meillo |
null-terminated the decoded base64 strings
|
2011-04-24 |
meillo |
removed protocol option from route config
|
2011-04-24 |
meillo |
reworked online_detect to the simpler online_query
|
2011-04-24 |
meillo |
bug fix: off-by-one in pipe aliases
|
2011-04-24 |
meillo |
added alias examples to man page
|
2011-04-24 |
meillo |
bug fix: inverted condition
|
2011-04-24 |
meillo |
clarified local_addresses in man page
|
2011-04-24 |
meillo |
refactored complex conditions
|
2010-12-09 |
markus schnalke |
manual formating of Received: hdrs; changed hdr for local receival
|
2010-12-09 |
markus schnalke |
replaced header_fold() with a better implementation
|
2010-12-09 |
markus schnalke |
improved unused function header_fold()
|
2010-12-09 |
markus schnalke |
refactoring
|
2010-12-09 |
markus schnalke |
free memory in spool read for continuation header lines
|
2010-12-09 |
markus schnalke |
fixed compile error; removed PROT_BSMTP; made protocol names ucase
|
2010-12-09 |
markus schnalke |
refactoring
|
2010-12-09 |
markus schnalke |
added a description of how I create a masqmail release
|
2010-12-09 |
markus schnalke |
ran aclocal and autoconf
|
2010-12-09 |
markus schnalke |
updated devel/list-versions to detect version number suffixes
|
2010-12-09 |
markus schnalke |
bumped version number
|
2010-12-08 |
markus schnalke |
Added tag 0.3.1 for changeset 5a93bdc261ba
|
2010-12-08 |
markus schnalke |
No, we don't have that many bugs any more, I believe. ;-)
0.3.1
|
2010-12-08 |
markus schnalke |
updated ChangeLog, NEWS and date/version in the man pages
|
2010-12-08 |
markus schnalke |
mark -qo (without argument) obsolete
|
2010-12-08 |
markus schnalke |
reformating of code
|
2010-12-07 |
markus schnalke |
FIXME comment: where to log while reading the config file?
|
2010-12-07 |
markus schnalke |
updated ChangeLog and NEWS
|
2010-12-07 |
markus schnalke |
further, minor, improvements to man/masqmail.8
|
2010-12-07 |
markus schnalke |
Heavily reworked man/masqmail.8
|
2010-12-07 |
markus schnalke |
recognize the program name `newaliases' too
|
2010-12-07 |
markus schnalke |
improved man/masqmail.8 heavily
|
2010-12-07 |
markus schnalke |
-q and -qo are non-exclusive
|
2010-12-07 |
markus schnalke |
modes are now enforced exclusive
|
2010-12-06 |
markus schnalke |
heavy refactoring of deliver.c
|
2010-12-06 |
markus schnalke |
moved some code around
|
2010-12-06 |
markus schnalke |
added -bm for mode accept (the other MTAs have it too)
|
2010-12-06 |
markus schnalke |
minor refactorings and cleanups
|
2010-12-04 |
markus schnalke |
for -t cmdline args are now added to the rcpt list instead of substracted
|
2010-12-03 |
markus schnalke |
removed comment, see previous commit
|
2010-12-03 |
markus schnalke |
fixed `To: alice, bob' with -t
|
2010-12-03 |
markus schnalke |
parse.c: comments, better debugging, tiny refactoring
|
2010-12-03 |
markus schnalke |
refactoring in the small
|
2010-12-03 |
markus schnalke |
heavy refactoring in the small of parse.c
|
2010-12-03 |
markus schnalke |
refactoring in the small
|
2010-12-03 |
markus schnalke |
comment: problems with `To: alice, bob' and -t
|
2010-12-03 |
markus schnalke |
removed ACC_DEL_RCPTS because it's always used with ACC_RCPT_FROM_HEAD
|
2010-12-03 |
markus schnalke |
comments (should we really exit failure in this case?)
|
2010-12-03 |
markus schnalke |
refactored mode_accept()
|
2010-12-03 |
markus schnalke |
removed obsolete commented code
|
2010-12-03 |
markus schnalke |
comments and a small refactoring
|
2010-12-02 |
markus schnalke |
removed now obsolete exit_code
|
2010-12-02 |
markus schnalke |
s/EXIT_SUCCESS/0/ && s/EXIT_FAILURE/1/
|
2010-12-02 |
markus schnalke |
fixed previous commit and excluded mode_version() from main()
|
2010-12-02 |
markus schnalke |
substituted get_progname() with a call to strrchr()
|
2010-12-02 |
markus schnalke |
made default mode sensible
|
2010-12-01 |
markus schnalke |
fixed -oem by removing it ;-)
|
2010-12-01 |
markus schnalke |
fixed -oi to really be the same as -i
|
2010-11-04 |
markus schnalke |
updated ChangeLog
|
2010-11-04 |
markus schnalke |
removed a magic number from time_interval()
|
2010-11-04 |
markus schnalke |
removed the obsolete pos argument from time_interval()
|
2010-11-04 |
markus schnalke |
updated ChangeLog and NEWS
|
2010-11-04 |
markus schnalke |
improved man/masqmail.8 in various ways but mostly for -oem
|
2010-11-04 |
markus schnalke |
moved run_queue to a new function
|
2010-11-04 |
markus schnalke |
moved the queue manipulation code to an new function
|
2010-11-04 |
markus schnalke |
refactored the cmdline argument processing
|
2010-11-01 |
markus schnalke |
refactored processing of -oXXX options
|
2010-11-01 |
markus schnalke |
ignoring -m switch now
|
2010-10-28 |
markus schnalke |
SMTP client: tries EHLO now always first
|
2010-10-27 |
markus schnalke |
removed ADDR_FLAG_NOEXPAND as it is not needed anymore
|
2010-10-25 |
markus schnalke |
renamed `alias_local_cmp' to `localpartcmp'
|
2010-10-25 |
markus schnalke |
renamed `alias_local_caseless' to `caseless_matching'
|
2010-10-25 |
markus schnalke |
made addr_isequal() and addr_isequal_parent() more flexible
|
2010-10-25 |
markus schnalke |
added myself to the copyright notice of route.c
|
2010-10-25 |
markus schnalke |
removed duplicated function prototypes
|
2010-10-25 |
markus schnalke |
refactored alias.c heavily
|
2010-10-25 |
markus schnalke |
minor improvements in wordings
|
2010-10-22 |
markus schnalke |
refactoring: new function split_rcpts() replaces two others
|
2010-10-22 |
markus schnalke |
debug msgs: improved the display of function return values
|
2010-10-22 |
markus schnalke |
removed additional new lines at the end of debug messages
|
2010-10-22 |
markus schnalke |
renamed the default route for the local net
|
2010-10-21 |
markus schnalke |
improved comments slightly
|
2010-07-26 |
meillo |
next version will be 0.3.1
|
2010-07-26 |
meillo |
Added tag 0.3.0 for changeset 4f999b3ee49d
|
2010-07-23 |
meillo |
updated ChangeLog and NEWS
0.3.0
|
2010-07-23 |
meillo |
install the files INSTALL and THANKS too
|
2010-07-23 |
meillo |
updated date and version of man pages
|
2010-07-23 |
meillo |
renamed contrib/ to admin/
|
2010-07-23 |
meillo |
renamed misc/ to devel/
|
2010-07-23 |
meillo |
removed oku's old email address
|
2010-07-23 |
meillo |
added my copyright to files I worked on
|
2010-07-23 |
meillo |
updated docs to STARTTLS wrappers
|
2010-07-23 |
meillo |
added support for STARTTLS wrappers
|
2010-07-23 |
meillo |
added a note to the long vs. int question in md5.h
|
2010-07-21 |
meillo |
added READMEs to describe the sense of contrib/ and misc/
|
2010-07-21 |
meillo |
added config-transition
|
2010-07-21 |
meillo |
small improvement of guess-hostname
|
2010-07-19 |
meillo |
added an executable bit
|
2010-07-19 |
meillo |
added misc/list-versions
|
2010-07-19 |
meillo |
added the contents of the old FAQ page
|
2010-07-19 |
meillo |
removed the old manual because it is really outdated now
|
2010-07-18 |
meillo |
added authors of contributed parts to AUTHORS
|
2010-07-18 |
meillo |
improved hmactest
|
2010-07-18 |
meillo |
replaced hmac_md5.c with an own implementation of RFC 2104
|
2010-07-18 |
meillo |
we need at least 32 bits, so let's take a long
|
2010-07-18 |
meillo |
replaced the MD5 implementation with the one of Solar Designer
|
2010-07-18 |
meillo |
added newlines to the end of log and debug messages where missing
|
2010-07-18 |
meillo |
removed commented code and replaced // by /* */
|
2010-07-16 |
meillo |
default listen_addresses: use 127.0.0.1 instead of `localhost'
|
2010-07-16 |
meillo |
REMOVED MAILDIR SUPPORT
|
2010-07-16 |
meillo |
removed the --disable-smtp-server configure option
|
2010-07-16 |
meillo |
removed --with-glib-static configure option
|
2010-07-16 |
meillo |
added docs/howto-static-linking
|
2010-07-16 |
meillo |
removed dns_getname() which was already commented
|
2010-07-16 |
meillo |
reworked resolvtest; let it build; refactored in lookup.c
|
2010-07-16 |
meillo |
generated Makefile.in to install THANKS file
|
2010-07-16 |
meillo |
the goal is to have less config options
|
2010-07-16 |
meillo |
added comment: TODO file may not be up-to-date
|
2010-07-16 |
meillo |
moved the CREDITS section from README to THANKS
|
2010-07-16 |
meillo |
There was still a /usr/sbin/masqmail path
|
2010-07-15 |
meillo |
specified group by name; added path to --with-glib-static
|
2010-07-15 |
meillo |
typographic fix: alignments in configure -h
|
2010-07-15 |
meillo |
REMOVED POP3 SUPPORT
|
2010-07-15 |
meillo |
further pop3_login stuff I forgot to remove
|
2010-07-15 |
meillo |
forgot to remove the pop3_login option in conf.c in the last commit
|
2010-07-15 |
meillo |
removed the pop-before-smtp (smtp-after-pop) function
|
2010-07-14 |
meillo |
refactoring and simplifications in mservdetect
|
2010-07-14 |
meillo |
improved mservdetect in various ways
|
2010-07-14 |
meillo |
added two setup guides
|
2010-07-14 |
meillo |
improved INSTALL (2nd sendmail link)
|
2010-07-14 |
meillo |
added an example route config with encryption
|
2010-07-14 |
meillo |
improved and simplified the example config
|
2010-07-14 |
meillo |
added a development helper script to update the date and version in man pages
|
2010-07-14 |
meillo |
added comments on how to compile with glib-1.2
|
2010-07-14 |
meillo |
do *not* use the openssl option -crlf in a wrapper command
|
2010-07-14 |
meillo |
added comments to deliver.c (stuff to check)
|
2010-07-14 |
meillo |
removed `remote_port' config option
|
2010-07-14 |
meillo |
better debug logging of outgoing SMTP dialogs
|
2010-07-14 |
meillo |
fixed a small typo in the debug output
|
2010-07-14 |
meillo |
merge
|
2010-07-14 |
meillo |
Documentation improvements in the INSTALL file and some man pages
|
2010-07-14 |
meillo |
Fix handling of --with-liblockfile=no or --without-liblockfile
|
2010-07-13 |
meillo |
merge
|
2010-07-13 |
meillo |
documented the wrapper option of route files better
|
2010-07-13 |
meillo |
merge
|
2010-07-13 |
meillo |
added a missing #include <sys/stat.h>
|
2010-07-13 |
meillo |
merge
|
2010-07-13 |
meillo |
write a log message when the daemon starts up
|
2010-07-08 |
meillo |
moved the PPP setup documentation from INSTALL to an own file
|
2010-07-08 |
meillo |
updated and improved INSTALL
|
2010-07-08 |
meillo |
removed the mserver feature
|
2010-07-08 |
meillo |
disabled POP3 support by default
|
2010-07-08 |
meillo |
guess-hostname: ordered guesses by quality
|
2010-07-08 |
meillo |
listen per default on localhost:25 now
|
2010-07-08 |
meillo |
added a script to guess the host's name
|
2010-07-08 |
meillo |
next version will be 0.3.0
|
2010-07-08 |
meillo |
documented that online_pipe must contain an absolute path
|
2010-07-08 |
meillo |
local_hosts defaults to localhost;foo;foo.example.org now
|
2010-07-08 |
meillo |
require host_name to be set in config file
|
2010-07-08 |
meillo |
shut down on errors reading config file
|
2010-07-08 |
meillo |
merge
|
2010-07-07 |
meillo |
local_hosts defaults to `localhost' now
|
2010-07-07 |
meillo |
mail_dir defaults to /var/mail now
|
2010-07-07 |
meillo |
default values for logdir and spooldir
|
2010-07-07 |
meillo |
Added tag 0.2.25 for changeset 115d3c92493b
|
2010-07-07 |
meillo |
updated ChangeLog and NEWS
0.2.25
|
2010-07-07 |
meillo |
moved rmail from bin (man1) to sbin (man8)
|
2010-07-07 |
meillo |
improved the Makefile (check diff for details)
|
2010-07-07 |
meillo |
small fix in Makefile if dirs do not exist
|
2010-07-07 |
meillo |
remove all installed dirs on `make uninstall'
|
2010-07-07 |
meillo |
credited Paolo's contributions
|
2010-07-07 |
meillo |
updated ChangeLog and NEWS
|
2010-07-06 |
meillo |
updated dates and versions in man pages
|
2010-07-06 |
meillo |
typo fixes in masqmail.route(5)
|
2010-07-06 |
meillo |
added a script that checks the documentation coverage of config options
|
2010-07-06 |
meillo |
/^\\fB/ in man pages indicates an option
|
2010-07-06 |
meillo |
documented, yet undocumented, set_h_reply_to_domain config option
|
2010-07-06 |
meillo |
added mailq.wmbiffrc by Paolo
|
2010-07-06 |
meillo |
check max length of addresses in SMTP dialog
|
2010-07-06 |
meillo |
fixed defer_all code
|
2010-07-06 |
meillo |
documented, yet undocumented, defer_all config option
|
2010-07-06 |
meillo |
documented, yet undocumented, spool_dir config option
|
2010-07-06 |
meillo |
small clarity improvement
|
2010-07-06 |
meillo |
fixed the use of max_size instead of max_size_delete
|
2010-07-06 |
meillo |
documented undocumented get config options
|
2010-07-06 |
meillo |
small typographic fix (`file' is a value)
|
2010-07-06 |
meillo |
moved the SIZE check to a better location
|
2010-07-06 |
meillo |
refactored SMTP_HELO and SMTP_EHLO cases
|
2010-07-01 |
meillo |
updated ChangeLog and NEWS
|
2010-07-01 |
meillo |
don't install the tests
|
2010-07-01 |
meillo |
Added tag 0.2.24 for changeset e01fed4846e4
|
2010-07-01 |
meillo |
next version will be 0.2.25
|
2010-07-01 |
meillo |
Todo: int may have only 16bit
|
2010-07-01 |
meillo |
better formating in debug log
|
2010-07-01 |
meillo |
added support for SMTP SIZE 0 (unlimited)
|
2010-07-01 |
meillo |
some annotations related to mail sending with SMTP SIZE
|
2010-07-01 |
meillo |
annotations at msg_calc_size()
|
2010-07-01 |
meillo |
added server-side SMTP SIZE support (patch by Paolo)
|
2010-06-30 |
meillo |
new warnmsg.tpl.it (Thanks to Paolo)
|
2010-06-30 |
meillo |
allow `:' unquoted too; updated masqmail.conf.5 (Thanks to Paolo)
|
2010-06-30 |
meillo |
better debugging output (thanks to Paolo)
|
2010-06-30 |
meillo |
Paolo's code and vanilla code differs
|
2010-06-30 |
meillo |
typographic fixes for masqmail.conf.5 (thanks to Paolo)
|
2010-06-29 |
meillo |
simplified a bit-operation based condition
|
2010-06-29 |
meillo |
changed name ACC_NODOT_TERM to ACC_DOT_IGNORE for better understanding
|
2010-06-29 |
meillo |
improved comments related to -t option
|
2010-06-29 |
meillo |
exchange of the if parts to simplify the condition
|
2010-06-29 |
meillo |
never create headers from recipients
|
2010-06-29 |
meillo |
masqmail now *always* removes Bcc: headers
|
2010-06-29 |
meillo |
add `undisclosed recipients' header if no recipient headers available
|
2010-06-25 |
meillo |
remove all mercurial files from distribution
|
2010-06-23 |
meillo |
improved man page in respect to the -t option
|
2010-06-23 |
meillo |
removed the ACC_NO_RECVD_HDR because it is never set
|
2010-06-22 |
meillo |
removed executable bits
|
2010-06-22 |
meillo |
the same typos in another file
|
2010-06-22 |
meillo |
fixed tiny typo
|
2010-06-21 |
meillo |
added man page for rmail(1)
|
2010-06-21 |
meillo |
man page of mservdetect talked about /usr/bin/masqmail :-O
|
2010-06-21 |
meillo |
small typo fix
|
2010-06-21 |
meillo |
masqmail's homepage moved prog.marmaro.de/masqmail -> marmaro.de/prog/masqmail
0.2.24
|
2010-06-21 |
meillo |
updated ChangeLog and NEWS
|
2010-06-21 |
meillo |
forgot again to commit the updated Makefile.in
|
2010-06-21 |
meillo |
updated docs (online_file, mserver_iface)
|
2010-06-21 |
meillo |
correct masqmail path in rmail script; remove docs on uninstall
|
2010-06-19 |
meillo |
added some words about exim to docs/uucp-setup
|
2010-06-19 |
meillo |
what about the `rmail' alias?
|
2010-06-19 |
meillo |
added a document that describes UUCP relevant stuff
|
2010-06-19 |
meillo |
added a comment on how to make group uucp trusted too
|
2010-06-19 |
meillo |
added rmail script from postfix
|
2010-06-19 |
meillo |
mservdetect should be listed in man section 1 if it resides in /.../bin/
|
2010-06-19 |
meillo |
is_ingroup(): check for the primary group of a user too
|
2010-06-19 |
meillo |
using is_privileged_user() to check here too
|
2010-06-19 |
meillo |
refactoring
|
2010-06-19 |
meillo |
moved check for NULL into destroy_message()
|
2010-06-19 |
meillo |
refactoring plus one small bugfix
|
2010-06-19 |
meillo |
man/Makefile.in was not up to date
|
2010-06-19 |
meillo |
next version will be 0.2.24
|
2010-06-16 |
meillo |
updated ChangeLog and NEWS
|
2010-06-16 |
meillo |
added copyright notices to files I improved
|
2010-06-16 |
meillo |
fixed correct processing of mails with data lines longer 4096 chars
|