diff Makefile.am @ 61:bdef5f279fde

refactoring in Makefile.am
author meillo@marmaro.de
date Sat, 29 May 2010 23:43:32 +0200
parents 6ab62592cac4
children 610cd4e09b91
line wrap: on
line diff
--- a/Makefile.am	Sat May 29 22:57:17 2010 +0200
+++ b/Makefile.am	Sat May 29 23:43:32 2010 +0200
@@ -1,46 +1,51 @@
-EXTRA_DIST = \
-examples/* docs/* man/* tpl/* \
-INSTALL.agenda INSTALL.ipaq agenda-config.site
+EXTRA_DIST = examples/* docs/* man/* tpl/*
 
 SUBDIRS = src man
 
 install-data-local: log_dir spool_dir uid_bit conf_dir tpl_dir run_dir doc_dir
 
+
 conf_dir: $(DESTDIR)@with_confdir@
 
 $(DESTDIR)@with_confdir@:
 	install -d $(DESTDIR)@with_confdir@
 
+
 tpl_dir: $(DESTDIR)@datadir@/tpl
 
 $(DESTDIR)@datadir@/tpl: conf_dir
 	install -d $(DESTDIR)@datadir@/masqmail/tpl
-	install -m 644 tpl/failmsg.tpl $(DESTDIR)@datadir@/masqmail/tpl
-	install -m 644 tpl/failmsg.tpl.* $(DESTDIR)@datadir@/masqmail/tpl
-	install -m 644 tpl/warnmsg.tpl $(DESTDIR)@datadir@/masqmail/tpl
-	install -m 644 tpl/warnmsg.tpl.* $(DESTDIR)@datadir@/masqmail/tpl
+	cp tpl/* $(DESTDIR)@datadir@/masqmail/tpl
+	chmod 644 $(DESTDIR)@datadir@/masqmail/tpl/*
 
-doc_dir: conf_dir
+
+doc_dir:
 	install -d $(DESTDIR)@docdir@
 	cp -r docs $(DESTDIR)@docdir@
 	cp -r examples $(DESTDIR)@docdir@
 	cp ChangeLog NEWS AUTHORS COPYING README TODO $(DESTDIR)@docdir@
 
-log_dir: $(DESTDIR)@with_logdir@
-
-spool_dir: $(DESTDIR)@with_spooldir@
 
 uid_bit: $(DESTDIR)@prefix@/sbin/masqmail
 	chmod u+s $(DESTDIR)@prefix@/sbin/masqmail
 
+
 run_dir:
 	install -d -o @with_user@ -g @with_group@ $(DESTDIR)/var/run/masqmail
 
+
+
+log_dir: $(DESTDIR)@with_logdir@
+
 $(DESTDIR)@with_logdir@:
 	[ -d `dirname $(DESTDIR)@with_logdir@` ] || \
 		install -d `dirname $(DESTDIR)@with_logdir@`
 	install -d -o @with_user@ -g @with_group@ $(DESTDIR)@with_logdir@
 
+
+
+spool_dir: $(DESTDIR)@with_spooldir@
+
 $(DESTDIR)@with_spooldir@:
 	[ -d `dirname $(DESTDIR)@with_spooldir@` ] || \
 		install -d `dirname $(DESTDIR)@with_spooldir@`