diff configure.ac @ 419:d209b4846f2b

The pid files goes to /var/run/masqmail.pid now. Added --with-piddir. Now we can change the pid dir to /run on system that did this transition.
author markus schnalke <meillo@marmaro.de>
date Tue, 29 May 2012 21:35:17 +0200
parents 7fe36ba87598
children f37384470855
line wrap: on
line diff
--- a/configure.ac	Tue May 29 21:33:49 2012 +0200
+++ b/configure.ac	Tue May 29 21:35:17 2012 +0200
@@ -188,6 +188,15 @@
 AC_DEFINE_UNQUOTED(CONF_DIR, "${with_confdir}", [The configuration file location])
 AC_SUBST(with_confdir)
 
+dnl dir for pid files
+AC_ARG_WITH(piddir,
+	[  --with-piddir=DIR       directory for pid files [/var/run]],
+	,
+	with_piddir='/var/run'
+	)
+AC_DEFINE_UNQUOTED(PID_DIR, "${with_piddir}", [The pid file location])
+AC_SUBST(with_piddir)
+
 test "x$prefix" = xNONE && prefix="$ac_default_prefix"
 
 dnl well, /me/ thought that autoconf should make things _easy_ ... -- oku