diff configure.ac @ 151:e20fe8c9936a

default values for logdir and spooldir we also have defines for LOG_DIR and SPOOL_DIR now
author meillo@marmaro.de
date Wed, 07 Jul 2010 10:32:00 +0200
parents 311d4ac8a2eb
children 27363b36a28c
line wrap: on
line diff
--- a/configure.ac	Tue Jul 06 20:16:33 2010 +0200
+++ b/configure.ac	Wed Jul 07 10:32:00 2010 +0200
@@ -247,10 +247,11 @@
 
 dnl log and spool directories
 AC_ARG_WITH(logdir,
-	[  --with-logdir=DIR        set log directory [/var/masqmail]],
+	[  --with-logdir=DIR        set log directory [/var/log/masqmail]],
 	,
         with_logdir='/var/log/masqmail/'
 	)
+AC_DEFINE_UNQUOTED(LOG_DIR, "${with_logdir}", [The log directory])
 AC_SUBST(with_logdir)
 
 AC_ARG_WITH(spooldir,
@@ -258,6 +259,7 @@
 	,
 	with_spooldir='/var/spool/masqmail/'
 	)
+AC_DEFINE_UNQUOTED(SPOOL_DIR, "${with_spooldir}", [The spool directory])
 AC_SUBST(with_spooldir)
 
 dnl configuration file