Mercurial > masqmail
comparison debian/rules @ 0:08114f7dcc23 0.2.21
this is masqmail-0.2.21 from oliver kurth
author | meillo@marmaro.de |
---|---|
date | Fri, 26 Sep 2008 17:05:23 +0200 |
parents | |
children | af25f5c39d90 |
comparison
equal
deleted
inserted
replaced
-1:000000000000 | 0:08114f7dcc23 |
---|---|
1 #!/usr/bin/make -f | |
2 | |
3 export DH_COMPAT=3 | |
4 | |
5 # Uncomment this to turn on verbose mode. | |
6 #export DH_VERBOSE=1 | |
7 DOC = usr/doc | |
8 MAN = usr/man | |
9 DAT = usr/lib | |
10 | |
11 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | |
12 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | |
13 # FOR AUTOCONF 2.52 AND NEWER ONLY | |
14 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE)) | |
15 confflags += --build $(DEB_HOST_GNU_TYPE) | |
16 else | |
17 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE) | |
18 endif | |
19 | |
20 build: build-stamp | |
21 build-stamp: | |
22 dh_testdir | |
23 | |
24 # Add here commands to compile the package. | |
25 ./configure $(confflags) \ | |
26 --prefix=/usr --mandir='$${prefix}/share/man' \ | |
27 --with-logdir=/var/log/masqmail \ | |
28 --with-spooldir=/var/spool/masqmail \ | |
29 --with-user=mail --with-group=mail \ | |
30 --with-confdir=/etc/masqmail \ | |
31 --with-liblockfile \ | |
32 --enable-auth \ | |
33 --enable-ident \ | |
34 --enable-maildir | |
35 $(MAKE) | |
36 | |
37 touch build-stamp | |
38 | |
39 clean: | |
40 dh_testdir | |
41 dh_testroot | |
42 rm -f build-stamp | |
43 | |
44 # Add here commands to clean up after the build process. | |
45 -$(MAKE) clean | |
46 -$(MAKE) distclean | |
47 rm -f tests/{test.conf,local.sh,smtpout.sh} | |
48 # see /usr/share/doc/autotools-dev/README.Debian.gz | |
49 -test -r /usr/share/misc/config.sub && \ | |
50 cp -f /usr/share/misc/config.sub config.sub | |
51 -test -r /usr/share/misc/config.guess && \ | |
52 cp -f /usr/share/misc/config.guess config.guess | |
53 rm -f config.log | |
54 | |
55 dh_clean | |
56 | |
57 install: build | |
58 dh_testdir | |
59 dh_testroot | |
60 dh_clean -k | |
61 dh_installdirs | |
62 | |
63 # Add here commands to install the package into debian/masqmail. | |
64 $(MAKE) DESTDIR=`pwd`/debian/masqmail install | |
65 rmdir debian/masqmail/var/spool/masqmail/input \ | |
66 debian/masqmail/var/spool/masqmail/lock \ | |
67 debian/masqmail/var/spool/masqmail/popuidl \ | |
68 debian/masqmail/var/spool/masqmail debian/masqmail/var/spool \ | |
69 debian/masqmail/var/log/masqmail debian/masqmail/var/log | |
70 | |
71 rm -f debian/masqmail/usr/bin/expandtest debian/masqmail/usr/bin/readtest | |
72 install -m 755 debian/newaliases debian/masqmail/usr/bin/. | |
73 install -m 755 debian/masqmail.ip-up debian/masqmail/etc/ppp/ip-up.d/1masqmail | |
74 install -m 755 debian/masqmail.ip-up debian/masqmail/etc/network/if-up.d/1masqmail | |
75 install -m 755 debian/masqmail.ip-up debian/masqmail/etc/ppp/ip-down.d/99masqmail | |
76 install -m 755 debian/masqmail.ip-up debian/masqmail/etc/network/if-down.d/99masqmail | |
77 | |
78 install -m 644 debian/masqmail.logrotate debian/masqmail/etc/logrotate.d/masqmail | |
79 | |
80 | |
81 # Build architecture-independent files here. | |
82 binary-indep: build install | |
83 # We have nothing to do by default. | |
84 | |
85 # Build architecture-dependent files here. | |
86 binary-arch: build install | |
87 cp debian/masqmail.lintian debian/masqmail/usr/share/lintian/overrides/masqmail | |
88 # dh_testversion | |
89 dh_testdir | |
90 dh_testroot | |
91 dh_installdebconf | |
92 dh_installdocs | |
93 rm -f debian/masqmail/usr/share/doc/masqmail/INSTALL | |
94 ##cp -r docs debian/masqmail/$(DOC)/masqmail/html | |
95 dh_installexamples examples/* tests | |
96 # dh_installmenu | |
97 # dh_installemacsen | |
98 dh_installinit | |
99 # dh_installcron | |
100 dh_installman debian/mailq.8 debian/mailrm.8 debian/newaliases.8 debian/sendmail.8 | |
101 # dh_undocumented | |
102 dh_installchangelogs ChangeLog | |
103 dh_link | |
104 dh_strip | |
105 dh_compress | |
106 dh_fixperms -X/usr/sbin/masqmail | |
107 dh_installdeb | |
108 dh_shlibdeps | |
109 dh_gencontrol | |
110 # dh_makeshlibs | |
111 dh_md5sums | |
112 dh_builddeb | |
113 | |
114 source diff: | |
115 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false | |
116 | |
117 binary: binary-indep binary-arch | |
118 .PHONY: build clean binary-indep binary-arch binary install |