meillo@0: #!/usr/bin/make -f
meillo@0: # -*- makefile -*-
meillo@0: # Sample debian/rules that uses debhelper.
meillo@0: # This file was originally written by Joey Hess and Craig Small.
meillo@0: # As a special exception, when this file is copied by dh-make into a
meillo@0: # dh-make output file, you may use that output file without restriction.
meillo@0: # This special exception was added by Craig Small in version 0.37 of dh-make.
meillo@0: 
meillo@0: # Uncomment this to turn on verbose mode.
meillo@0: #export DH_VERBOSE=1
meillo@0: 
meillo@0: 
meillo@12: build:
meillo@0: 
meillo@0: clean:
meillo@0: 	dh_testdir
meillo@0: 	dh_testroot
meillo@21: 	dh_clean
meillo@0: 
meillo@12: install:
meillo@0: 	dh_testdir
meillo@0: 	dh_testroot
meillo@0: 	dh_installdirs
meillo@0: 
meillo@0: 	# Add here commands to install the package into debian/genwebgallery.
meillo@0: 	$(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install
meillo@0: 
meillo@0: 
meillo@0: # Build architecture-independent files here.
meillo@12: binary-indep: install
meillo@0: 	dh_testdir
meillo@0: 	dh_testroot
meillo@9: 	dh_installchangelogs ChangeLog
meillo@0: 	dh_installdocs
meillo@0: 	dh_installman
meillo@0: 	dh_compress
meillo@0: 	dh_fixperms
meillo@0: 	dh_installdeb
meillo@0: 	dh_gencontrol
meillo@0: 	dh_md5sums
meillo@0: 	dh_builddeb
meillo@0: 
meillo@0: # Build architecture-dependent files here.
meillo@12: binary-arch:
meillo@0: 
meillo@21: binary: binary-indep binary-arch
meillo@12: 
meillo@0: .PHONY: build clean binary-indep binary-arch binary install configure