Mercurial > genwebgallery
comparison debian/rules @ 0:9f4fa0bc1584 0.3
initial commit
author | meillo@marmaro.de |
---|---|
date | Thu, 22 Nov 2007 21:13:25 +0100 |
parents | |
children | 626dacb5193e |
comparison
equal
deleted
inserted
replaced
-1:000000000000 | 0:9f4fa0bc1584 |
---|---|
1 #!/usr/bin/make -f | |
2 # -*- makefile -*- | |
3 # Sample debian/rules that uses debhelper. | |
4 # This file was originally written by Joey Hess and Craig Small. | |
5 # As a special exception, when this file is copied by dh-make into a | |
6 # dh-make output file, you may use that output file without restriction. | |
7 # This special exception was added by Craig Small in version 0.37 of dh-make. | |
8 | |
9 # Uncomment this to turn on verbose mode. | |
10 #export DH_VERBOSE=1 | |
11 | |
12 | |
13 | |
14 | |
15 CFLAGS = -Wall -g | |
16 | |
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) | |
18 CFLAGS += -O0 | |
19 else | |
20 CFLAGS += -O2 | |
21 endif | |
22 | |
23 configure: configure-stamp | |
24 configure-stamp: | |
25 dh_testdir | |
26 # Add here commands to configure the package. | |
27 | |
28 touch configure-stamp | |
29 | |
30 | |
31 build: build-stamp | |
32 | |
33 build-stamp: configure-stamp | |
34 dh_testdir | |
35 | |
36 # Add here commands to compile the package. | |
37 $(MAKE) | |
38 #docbook-to-man debian/genwebgallery.sgml > genwebgallery.1 | |
39 | |
40 touch $@ | |
41 | |
42 clean: | |
43 dh_testdir | |
44 dh_testroot | |
45 rm -f build-stamp configure-stamp | |
46 | |
47 # Add here commands to clean up after the build process. | |
48 -$(MAKE) clean | |
49 | |
50 dh_clean | |
51 | |
52 install: build | |
53 dh_testdir | |
54 dh_testroot | |
55 dh_clean -k | |
56 dh_installdirs | |
57 | |
58 # Add here commands to install the package into debian/genwebgallery. | |
59 $(MAKE) DESTDIR=$(CURDIR)/debian/genwebgallery install | |
60 | |
61 | |
62 # Build architecture-independent files here. | |
63 binary-indep: build install | |
64 dh_testdir | |
65 dh_testroot | |
66 dh_installchangelogs | |
67 dh_installdocs | |
68 dh_installexamples | |
69 # dh_install | |
70 # dh_installmenu | |
71 # dh_installdebconf | |
72 # dh_installlogrotate | |
73 # dh_installemacsen | |
74 # dh_installpam | |
75 # dh_installmime | |
76 # dh_python | |
77 # dh_installinit | |
78 # dh_installcron | |
79 # dh_installinfo | |
80 dh_installman | |
81 dh_link | |
82 dh_strip | |
83 dh_compress | |
84 dh_fixperms | |
85 # dh_perl | |
86 # dh_makeshlibs | |
87 dh_installdeb | |
88 dh_shlibdeps | |
89 dh_gencontrol | |
90 dh_md5sums | |
91 dh_builddeb | |
92 | |
93 # Build architecture-dependent files here. | |
94 binary-arch: build install | |
95 # We have nothing to do by default. | |
96 | |
97 binary: binary-indep binary-arch | |
98 .PHONY: build clean binary-indep binary-arch binary install configure |