Mercurial > bday
comparison debian/rules @ 11:9bd926eb89fa
added debian/ stuff; fix in Makefile
author | meillo@marmaro.de |
---|---|
date | Wed, 19 Dec 2007 01:46:47 +0100 |
parents | |
children | a1ac59b7916b |
comparison
equal
deleted
inserted
replaced
10:6d25afd91132 | 11:9bd926eb89fa |
---|---|
1 #!/usr/bin/make -f | |
2 # Sample debian/rules that uses debhelper. | |
3 # GNU copyright 1997 to 1999 by Joey Hess. | |
4 | |
5 # Uncomment this to turn on verbose mode. | |
6 #export DH_VERBOSE=1 | |
7 | |
8 # This is the debhelper compatibility version to use. | |
9 #export DH_COMPAT=4 | |
10 | |
11 CFLAGS = -g | |
12 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) | |
13 CFLAGS += -O0 | |
14 else | |
15 CFLAGS += -O2 | |
16 endif | |
17 | |
18 build: build-stamp | |
19 build-stamp: | |
20 dh_testdir | |
21 | |
22 # Add here commands to compile the package. | |
23 $(MAKE) build | |
24 | |
25 touch build-stamp | |
26 | |
27 clean: | |
28 dh_testdir | |
29 dh_testroot | |
30 rm -f build-stamp | |
31 | |
32 # Add here commands to clean up after the build process. | |
33 -$(MAKE) clean | |
34 | |
35 dh_clean | |
36 | |
37 install: build | |
38 dh_testdir | |
39 dh_testroot | |
40 dh_clean -k | |
41 dh_installdirs | |
42 | |
43 # Add here commands to install the package into debian/gentoo. | |
44 $(MAKE) install DESTDIR=$(CURDIR)/debian/bday | |
45 | |
46 # Build architecture-independent files here. | |
47 binary-indep: build install | |
48 # We have nothing to do by default. | |
49 | |
50 # Build architecture-dependent files here. | |
51 binary-arch: build install | |
52 dh_testdir | |
53 dh_testroot | |
54 # dh_installdebconf | |
55 dh_installdocs | |
56 dh_installexamples | |
57 # dh_installmenu | |
58 # dh_installlogrotate | |
59 # dh_installemacsen | |
60 # dh_installpam | |
61 # dh_installmime | |
62 # dh_installinit | |
63 # dh_installcron | |
64 dh_installman | |
65 # dh_installinfo | |
66 # dh_undocumented | |
67 dh_installchangelogs ChangeLog | |
68 dh_link | |
69 dh_strip | |
70 dh_compress | |
71 dh_fixperms | |
72 # dh_makeshlibs | |
73 dh_installdeb | |
74 # dh_perl | |
75 dh_shlibdeps | |
76 dh_gencontrol | |
77 dh_md5sums | |
78 dh_builddeb | |
79 | |
80 binary: binary-indep binary-arch | |
81 .PHONY: build clean binary-indep binary-arch binary install |