baum

view debian/rules @ 44:bc693c51970d

updated TODO; minor stuff in debian/
author meillo@marmaro.de
date Sat, 01 Mar 2008 21:24:00 +0100
parents ca56c1b3fb67
children
line source
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 # This is the debhelper compatibility version to use.
9 #export DH_COMPAT=4
11 CFLAGS = -g
12 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
13 CFLAGS += -O0
14 else
15 CFLAGS += -O2
16 endif
18 build: build-stamp
19 build-stamp:
20 dh_testdir
22 # Add here commands to compile the package.
23 $(MAKE) build
25 touch build-stamp
27 clean:
28 dh_testdir
29 dh_testroot
30 rm -f build-stamp
32 # Add here commands to clean up after the build process.
33 -$(MAKE) clean
35 dh_clean
37 install: build
38 dh_testdir
39 dh_testroot
40 dh_clean -k
41 dh_installdirs
43 # Add here commands to install the package into debian/gentoo.
44 $(MAKE) install DESTDIR=$(CURDIR)/debian/baum
46 # Build architecture-independent files here.
47 binary-indep: build install
48 # We have nothing to do by default.
50 # Build architecture-dependent files here.
51 binary-arch: build install
52 dh_testdir
53 dh_testroot
54 dh_installdocs
55 dh_installexamples examples/*
56 dh_installman
57 dh_installchangelogs ChangeLog
58 dh_link
59 dh_strip
60 dh_compress
61 dh_fixperms
62 dh_makeshlibs
63 dh_installdeb
64 dh_shlibdeps
65 dh_gencontrol
66 dh_md5sums
67 dh_builddeb
69 binary: binary-indep binary-arch
70 .PHONY: build clean binary-indep binary-arch binary install